TheCreedBR

Member
 PSN Profile
  • Content count

    1
  • Joined

  • Last visited

Everything posted by TheCreedBR

  1. press the option button in the game and going to settings just turn off auto instant replays and pga tour pro highlights, it worked for me.