Jump to content

Light Reforged bug


Recommended Posts

I was at 200/700 valor rank points for the last step of this quest when I maxed my rank and reset it. Now the progress shows 0/700 and does not go up after completed matches. 

apparently this is a commonly known bug. Just wondering if anyone here found a way around it. Does starting a new character help? Abandoning and picking it up again does NOT do the trick. :(

Link to comment
Share on other sites

Just so you know making a character won't do it, Light Reforged is a quest registered across all your account's characters. Only fix I can think of is literally using another Bungie account. 


We'll see with today's update, been stuck with this since November. 


EDIT : They fixed it !!

Edited by TerryTopsis
Link to comment
Share on other sites

It's so weird. I don't know that they fixed it, but I was finally able to earn the trophy nonetheless.


I created a new Titan last night (thinking that would resolve it) and played up until accessing the Tower and the Light Reforged quest. It had me where I'd left off on my prior Titan, the last 700 pts. It was showing 0/700, which I thought was fair considering it was a new character. But when I completed my first match, it stayed at 0 instead of moving up to 10/700. At this point, I decided to check the companion app, which showed me at 699/700 (if anything, I should have only been at around 250-300 or so but wasn't complaining). One more completed match and despite still showing 0/700 the quest step was marked as completed and I was able to turn it into Shaxx for the trophy. That's my story.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...