Jump to content

Game freezes on the graveyard level, anyone else experienced this?


Recommended Posts

Hello folks, I'm aware this forum is pretty abandoned but I'm feeling a bit desperate and hoping for some advice / help. So I returned to this game after a long absence, hoping to grab the last trophies I can get with the loss of the online. I started professional difficulty, but ran into the lost save issue when I tried to pick up in the Library level. I decided to simply run through the game in one sitting, picking up a few trophies at a time until I was finished.

 

My first run through on casual went fine, no issues aside from the 30 second or so freeze you can get in the Library, when all the book shelves start moving. After that I completed the game and got 3 of my needed trophies. The problem started after that. Returning to casual mode to pick up the 'nice shooting tex' trophy I got all the way to the end, no issues, not even any issues in the Library, but as soon as you walk through the crypt door, after defeating the first crypt monster and returning the keystone to the proper location, right when you walk up the stairs, Ray starts talking and the objective changes to 'Find the other Ghostbusters' - boom. it freezes. I can hear rainfall in the background, but the character will not move. Nothing moves. This has now happened twice. The first time I tried sprinting to go pick up the cursed artifact tree when it froze, and the second time I decided to ignore the tree, not sprint, and instead jog normally and the second Ray opened his mouth to comment on the weather it froze. This, combined with the game not reading any save data means I'm losing hours at a time. I deleted and reinstalled the game data in between the two attempts, so I'm not sure what could be causing this. I checked my disc, and it seems fine. No scratches or anything. A few fingerprints I've cleaned away, thats all.

 

Has anybody experienced this before? Or know anyone who has mentioned this before? I tried searching online, and the only mention I found were guys talking about the ps2 version, with the last message being 11 years ago, no mention of a work around. Is this just a random chance and I've been unlucky both times, or could it be something else? A disc problem, save data issue or HDD problem? I'm just hoping I can be pointed in the right direction here, as I'm feeling pretty demoralised at attempting another run, even on casual. And god forbid this happens on professional...

I hope somebody can help me out here.

Link to comment
Share on other sites

Common issues: online connectivity (go offline), disc reading issues (bad disc), installation issues (try to reinstall / hdd might be dying if it makes unusual ticking sounds), shitty game (out of luck / find some workaround).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...