Jump to content

Possible glitch - Magnus Walker speed race


Recommended Posts

Hi all, 


Hopefully someone can shed some light on this issue.....


I've played the game all the way through up till the mission 'Red Lines' where you race vs Magnus Walker one on one. Speed is the only quest chain I have not yet completed and is around 79%


I raced him and at the last moment ended up losing to him at which point I got a message from him saying essentially try again....the problem is there is no indicator in game for me to race him again. None of the 'hang out spots' are available, none of the crew are contactable, I've clicked through all the messages, gone to the garage, changed cars, tried one of the Eddie challenges and even the separate red lines event and the Magnus race will not spawn. I've quit the game repeatedly and still nothing. Feels like I've tried everything I can think of but still can't get the invite to race him again


Any ideas?


Update - ater several hours left idle and completing a second Eddie challenge, Magnus contacted me with the 'business or pleasure' mission which I hadn't previously attempted. So it seems the game skipped this mission initially. Once that was completed the missions have all spawned as expected. Just in case anyone has the same issue


Edited by Artty44
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...