Batmobile Upgrade 2 Trophy Glitch + Fix

1 post in this topic

Strangely this occurred last night.


I had about 900 K in studs, and I was going to upgrade the Batmobile to grab the 2 trophies for that, plus the 3rd trophy for the Pink paint job.  I was unsure how the process worked, and did I even need to save it to the toy tag or would the game just remember that I had done the upgrades to the vehicle?


Well I figured the trophies would pop in succession as I purchased the upgrades, and perhaps I was going a bit fast.  However after I purchased all of the level 1 upgrades, and then the level 2 upgrades, I didn't "Save to the Toy Tag", I just started buying upgrades for the 3rd Upgrade Model.  The trophy for the 2nd Upgrade did not pop, I kept unlocking until I ran out of studs and then finally saved to the toy tag.  It gave me the trophy for the 3rd Upgrade, yet not the 2nd.  Then I figured out how to change the color to Pink for that trophy.  Then I saved, quit, synced, went upstairs, updated profile here on PSN and I noticed the 2nd Upgrade trophy was missing.




I went back downstairs as I was quite bothered, hoping I didn't have to make a second playthrough just for this trophy.  I also had switched between the 3 forms while in the Voltron Hub driving around, which didn't cause the trophy to pop.  I went back into the Upgrades menu and only had the Batmobile on the toy pad, so it opened to that.  I then put my selection choice on upgrade 2's design at the top of the screen, and then I noticed an option on the left top corner that says "Reset Toy Tag".  While I hoped it wouldn't delete all of my upgrades, I was thinking lets give it a shot, as I can always get more studs, and sure enough after doing that I kept my upgrades and the model 2 trophy popped.


I can confirm this is a glitch where it seems to pass over the upgrade 2 trophy, if you don't save to the toy tag when you have upgraded to Model 2, BEFORE you upgrade to model 3.  Otherwise if this should occur to you, just follow the steps I did in "THE FIX" above.  


Needless to stay the time stamps are about a 1/2 hour apart due to me not catching it right away while upgrading.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.