OverHypedG

[VIDEO] 1 500 000 credits per hour

246 posts in this topic

On 3/19/2022 at 3:02 PM, Septomor said:

 

 

New Script

 

In the controller settings set set D-pad down to nitro

 

Good news! I made another script this time for Pan America 1. It's 52k for a clean race which we can cheese. I've gotten the race time to be a consistent 4:02-4:07 times always with clean race bonus. This is the time a lot of people use when they say Credits/Hour, which would make this a 780k/hr method. But I'm including menu times which are way higher for this particular method. The actual amount you can expect is 550k/hr, 100% afk. If you race manually it takes a minute less so it's still more effective of course to play the game. 

 

Here's the AHK script for Pan American (you can edit this)

 

Here is an executable for people who don't want to download autohotkey (cannot edit)

 

Add a settings page for tuning your Tomahawk, and only change the tires to Sports: Hard (I found these consistently the fastest). Start the Pan American Championship (bottom of the America/Europe/Asia menu), start the first race, pause and hover over retry. Start script. And that's all, let me know how it works guys!

 

Edit: Forgot to mention, I also have set controller steering to -2, I'm not certain it matters with directional buttons but it might

 

Had this running overnight for around 9 hours with no issues. Tried it again a few hours later and after about 1 hour, I get the same issue others have stated, where it selects a replay vs going to next race. All settings are same as before but it has happened on 3 separate occasions. Any ideas what the issue is? Could it be due to old oil, even though PP is the same? My opening lap is ~42.xx and laps 2-6 are 39.6-8xx. 

I've now adjusted car height and turned off counter steer to get to pp ~902 and laps in 38.xxx territory so hopefully that works.

1

Share this post


Link to post
Share on other sites
Just now, disco_potato said:

 

Had this running overnight for around 9 hours with no issues. Tried it again a few hours later and after about 1 hour, I get the same issue others have stated, where it selects a replay vs going to next race. All settings are same as before but it has happened on 3 separate occasions. Any ideas what the issue is? Could it be due to old oil, even though PP is the same? My opening lap is ~42.xx and laps 2-6 are 39.6-8xx. 

I've now adjusted car height and turned off counter steer to get to pp ~902 and laps in 38.xxx territory so hopefully that works.


My guess it has something to do with menu button presses and not race time itself. If you were too slow for the script, you could increase that largest variable to give yourself more time before it goes into menuing phase.

My results were inconsistent until I adjusted this part at lines 106-111
 

PressX:
; Just for menuing, does not hold X down
    ControlSend,, {%accel% down}, ahk_id %id% 
	DllCall("Sleep", "UInt", 200)
    ControlSend,, {%accel% up}, ahk_id %id% 
    return

I figured that due to some random lags from my own hardware, 200 ms might not have been enough for button press to be registered properly via remote play, I increased it to 250 and been working fine so far.
Before this I also slightly increased time between presses at lines 179-184
 

Menu:
    loop, 9{
        gosub, PressX
    ;ToolTip, %A_Index% X, 100, 100
        Sleep, 1700
    }

From 1700 to 2200, just in case menu lags in game for some reason and misses a button press.

4

Share this post


Link to post
Share on other sites
9 minutes ago, TheSwordUserYT said:


My guess it has something to do with menu button presses and not race time itself. If you were too slow for the script, you could increase that largest variable to give yourself more time before it goes into menuing phase.

My results were inconsistent until I adjusted this part at lines 106-111
 

PressX:
; Just for menuing, does not hold X down
    ControlSend,, {%accel% down}, ahk_id %id% 
	DllCall("Sleep", "UInt", 200)
    ControlSend,, {%accel% up}, ahk_id %id% 
    return

I figured that due to some random lags from my own hardware, 200 ms might not have been enough for button press to be registered properly via remote play, I increased it to 250 and been working fine so far.
Before this I also slightly increased time between presses at lines 179-184
 

Menu:
    loop, 9{
        gosub, PressX
    ;ToolTip, %A_Index% X, 100, 100
        Sleep, 1700
    }

From 1700 to 2200, just in case menu lags in game for some reason and misses a button press.

I'm using the exe so no editing for now. Will download the editable script if my faster times don't address my issue. Thanks for the reply!

0

Share this post


Link to post
Share on other sites

A big thank you @Septomor

 

I have used both your SSX and Pan-Am scripts for a few days now, both work perfectly well.

 

You are the real anti-MTX hero lol

 

 

0

Share this post


Link to post
Share on other sites

Posted (edited)

I promise to make a dedicated thread later, I've been busy testing things out, seems Sports: Hard for front tires with Racing: Soft rear does better, Body Height Adjustment both 70, Anti-Roll both 10, getting 3:49-3:53 times. Also have been messing with tunings and trying other races for the most part today. I'm not sure how important it is for others as well, but if using PixelSearch I've got it up to 603k/hr, but this would mean you would have to keep the remote play window on screen the whole time. If anyone knows a solution around this I'd be happy to hear, moving it off screen does not seem to work. I'll also try getting a google sheet going later where people can submit their tunings and we can try optimizing it. Every second saved is +2000Cr/hr (which considering the grind is probably 100+ hours is decent time save), and there are too many setups for me to try on my own. 

 

If you want to try what I have so far with the settings above, cannot minimize or cover remote play window with another window, can still use computer otherwise.

 

wait on downloads, I've bonked something 

ahk

exe

Edited by Septomor
3

Share this post


Link to post
Share on other sites
5 hours ago, TheSwordUserYT said:


My guess it has something to do with menu button presses and not race time itself. If you were too slow for the script, you could increase that largest variable to give yourself more time before it goes into menuing phase.

My results were inconsistent until I adjusted this part at lines 106-111
 

PressX:
; Just for menuing, does not hold X down
    ControlSend,, {%accel% down}, ahk_id %id% 
	DllCall("Sleep", "UInt", 200)
    ControlSend,, {%accel% up}, ahk_id %id% 
    return

I figured that due to some random lags from my own hardware, 200 ms might not have been enough for button press to be registered properly via remote play, I increased it to 250 and been working fine so far.
Before this I also slightly increased time between presses at lines 179-184
 

Menu:
    loop, 9{
        gosub, PressX
    ;ToolTip, %A_Index% X, 100, 100
        Sleep, 1700
    }

From 1700 to 2200, just in case menu lags in game for some reason and misses a button press.

Yup, you were right. It eventually got out of sync likely due to missed button presses.

0

Share this post


Link to post
Share on other sites
1 hour ago, Septomor said:

I promise to make a dedicated thread later, I've been busy testing things out, seems Sports: Hard for front tires with Racing: Soft rear does better, Body Height Adjustment both 70, Anti-Roll both 10, getting 3:49-3:53 times. Also have been messing with tunings and trying other races for the most part today. I'm not sure how important it is for others as well, but if using PixelSearch I've got it up to 603k/hr, but this would mean you would have to keep the remote play window on screen the whole time. If anyone knows a solution around this I'd be happy to hear, moving it off screen does not seem to work. I'll also try getting a google sheet going later where people can submit their tunings and we can try optimizing it. Every second saved is +2000Cr/hr (which considering the grind is probably 100+ hours is decent time save), and there are too many setups for me to try on my own. 

 

If you want to try what I have so far with the settings above, cannot minimize or cover remote play window with another window, can still use computer otherwise.

 

wait on downloads, I've bonked something 

ahk

exe

I want to try pixelsearch ,  maybe it can save so many time per round,now i getting 3:50-3:52 times。

0

Share this post


Link to post
Share on other sites
16 minutes ago, pijing3 said:

I want to try pixelsearch ,  maybe it can save so many time per round,now i getting 3:50-3:52 times。

 

Alright, I figured the problem was I had the wrong coordinate mode selected. semi-happy with script below, my times for the last 4 races with settings above are

 

3:47.992,

3:48.788,

3:48.540, 

3:51.801 (hit 2 cars who wouldnt get out the way)

 

It's more optimized with faster menu'ing and pixelsearch, which now will start the menu'ing as quickly as it can. You cannot move the ps remote play window once it's moved by the script nor can you place other windows above it.

 

ahk

exe

2

Share this post


Link to post
Share on other sites
2 hours ago, Septomor said:

 

Alright, I figured the problem was I had the wrong coordinate mode selected. semi-happy with script below, my times for the last 4 races with settings above are

 

3:47.992,

3:48.788,

3:48.540, 

3:51.801 (hit 2 cars who wouldnt get out the way)

 

It's more optimized with faster menu'ing and pixelsearch, which now will start the menu'ing as quickly as it can. You cannot move the ps remote play window once it's moved by the script nor can you place other windows above it.

 

ahk

exe

i have test the script,but the pixelsearch is not work.The screen stays on showing the game duration

I'm using a sony 4k tv and I don't know if it has something to do with the resolution,ps remote will always remain in the upper left corner of the screen

when i used your latest parameters,my times for the last 5 races

 

3'46.1

3'46.4

3'45.8

3'46.3

3'49.7  (2 severe hits)

 
1

Share this post


Link to post
Share on other sites

After you finish the race, there should be a purple banner banner underneath the leaderboard right? I have pixel search look on that banner for the purple color there. it might depend on your pc monitor if you're using a filter for diming the screen or such. No worries, after the race is finished, exit the script and do Windows Key + "Window Spy", this is an ahk script that lets you peek at certain values that are important to us. Just hover your mouse over the purple box, and hold Ctrl to pause window spy. Then you can copy and paste the values (like I have from lines 154-158) and in particular copy the color and overwrite 0x3f1757 from the script. Hopefully that makes sense, I'm pretty tired so I have to sleep for now, I'll try making a guide in the morning.

1

Share this post


Link to post
Share on other sites
13 minutes ago, Septomor said:

After you finish the race, there should be a purple banner banner underneath the leaderboard right? I have pixel search look on that banner for the purple color there. it might depend on your pc monitor if you're using a filter for diming the screen or such. No worries, after the race is finished, exit the script and do Windows Key + "Window Spy", this is an ahk script that lets you peek at certain values that are important to us. Just hover your mouse over the purple box, and hold Ctrl to pause window spy. Then you can copy and paste the values (like I have from lines 154-158) and in particular copy the color and overwrite 0x3f1757 from the script. Hopefully that makes sense, I'm pretty tired so I have to sleep for now, I'll try making a guide in the morning.

Thank you so much hope you rest well

I will try carefully

0

Share this post


Link to post
Share on other sites

Posted (edited)

Maybe I'm an idiot or I'm missing something... @Septomor Why when starting the race, does my car hit the first and third car and then hits the one being 2nd place?

All settings are the same as you mentioned above and I'm using the intermediate difficulty.

Are we not looking for a clean race bonus with the script approach?

 

Edit: Nevermind.. it seems I got a clean race bonus even after hitting two cars...

Now l have to look for in this thread why it does not always click next race and goes to world GT series race instead of panam.

 

Edit2:

not clicking next race button > reason: timing issue due to having completed the daily marathon and there were additional clicks for the roulette ticket.

not clicking the Panam race after exiting and it was hovering over World GT series > reason: I had not completed the World GT series and it was the currently active menu cafe book.

Edited by RapiDuS
0

Share this post


Link to post
Share on other sites

What is the latest best grinding method for credits? I’ve searched this thread but to be honest i don’t know what’s patched and what isn’t. Can anyone just quote me the latest method that works please? 

0

Share this post


Link to post
Share on other sites
1 minute ago, Radford999 said:

What is the latest best grinding method for credits? I’ve searched this thread but to be honest i don’t know what’s patched and what isn’t. Can anyone just quote me the latest method that works please? 

 

Currently it seems to be Race 1 of the Pan Am Championship - 52.5k per race which takes around 4 minutes in a Tomahawk Road Car.

0

Share this post


Link to post
Share on other sites

@Septomor

Again, thank you for the update it's working great for me (laptop).

 

I edited the sizes in the previous version to extend a bit the height to get the menubar from the app not overlayed over the PS5 display.

It's not very practical when I have to do manual actions like oil change, relaunch...

I used variables to implement it in your script if your are interested.

 

I added these 2 constants :

width = 720
height := width*4/5

And changed these 2 lines :

PixelSearch, x, y, width/2, height*77/100, width/2+20, height*82/100, 0x3F1757, 20, Fast RGB
WinMove, ahk_id %id%,,  0, 0, width, height

 

0

Share this post


Link to post
Share on other sites
5 minutes ago, Radford999 said:

What is the latest best grinding method for credits? I’ve searched this thread but to be honest i don’t know what’s patched and what isn’t. Can anyone just quote me the latest method that works please? 

I'm still doing the ranch with the Toyota car. I know the championship race gives more, but for that I'd have to spend 1 million for a 15% increase in pay.

0

Share this post


Link to post
Share on other sites
4 minutes ago, DutchJordi said:

I'm still doing the ranch with the Toyota car. I know the championship race gives more, but for that I'd have to spend 1 million for a 15% increase in pay.

For me, it was well worth the investment cause I farmed 10 million credits completely AFK in the last 20 hours

1

Share this post


Link to post
Share on other sites

Posted (edited)

50 minutes ago, Radford999 said:

What is the latest best grinding method for credits? I’ve searched this thread but to be honest i don’t know what’s patched and what isn’t. Can anyone just quote me the latest method that works please? 

I've been doing 3 laps Sardegna Windmills (Europe) since the latest patch. 60k (40+20k) credits per 4 minutes. Something like 800-850K per hour, including menu/loading time. I don't do this AFK though.

Edited by Asimb0mb
0

Share this post


Link to post
Share on other sites
3 minutes ago, Radford999 said:

How can you do the pan am race AFK?

they are using a program to go afk through remote play, basically they are using the computer to race for them, its a little complicated to be honest

 

0

Share this post


Link to post
Share on other sites
8 minutes ago, CrazyAce842 said:

they are using a program to go afk through remote play, basically they are using the computer to race for them, its a little complicated to be honest

 

Not really

 

you need a windows pc/laptop

remote play app

and the script

 

The complicate part was done by the script author

1

Share this post


Link to post
Share on other sites

@Septomor Thank you, thank you, thank you. 

 

I'm not averse to grinding (In GT Sport I had the Jaguar Xj13 '66 and Ferrari 330 P4 '67 on the day they came out.), but the grind this time... You have saved GT 7 for me, thank you so much.

 

Some quick observations after using this to make 10million over night.

- Latency, MS and Internet disruptions will obviously affect the script so be mindful, as an i.e. I was playing a game this morning, running the script and watching Youtube videos, this would cause the script to go Out-Of-Sync. (should be obvious to most but thought to mention anyway.)

- Be mindful of your Oil Status ( and eventually engine condition and body rigidity) After my over night grind I noticed significantly slower lap times, resulting in a longer race, thus making the script once again OOS, after an oil change, everything was perfect. Though my engine and body are now showing "normal" condition instead of "excellent" so they may need to changed after several more hours.

- I tried running the script on all three AI Difficulties, sometimes you will shunt the AI in the rear, you sometimes get the clean bonus if contact was brief no matter how hard. If you are in contact for a period of time (stuck behind them and touching) you may not get the bonus even if the impact was low. As I'm running a script AFK I'm not bothered losing the bonus once in a while, but just wanted to point it out as it's not the scripts fault if you fail to achieve the Clean Bonus. 

 

All in all, I'm am extremely impressed, I know nothing about scripts but this was quick and easy. Just a couple of clicks and my poor hands are saved from RSI. 

 

PS. You have been using these types of scripts since 2017, did you use any in GT Sport and if so, have you still got it. Sorry, cheeky I know. :( 

0

Share this post


Link to post
Share on other sites
34 minutes ago, faridable said:

Can somebody do a videoguide?

For what reason?

1

Share this post


Link to post
Share on other sites

Posted (edited)

37 minutes ago, Ballyn13 said:

 

- Latency, MS and Internet disruptions will obviously affect the script so be mindful, as an i.e. I was playing a game this morning, running the script and watching Youtube videos, this would cause the script to go Out-Of-Sync. (should be obvious to most but thought to mention anyway.)

 

 

This.

 

I think button presses need some adjustment ie make the script to press each button for a slightly longer period of time. Especially menu navigation (down, left etc) as packet loss and lag make the script go out of sync.

 

I can leave the script running overnight no probs, but during the day, when there's more strain on my network, it goes out of sync rather often.

 

Perhaps the @Septomor could expose more variables to tweak?

Edited by alexwise
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.