Septomor

AFK methods for farming (GT 1.09 update)

705 posts in this topic

Posted (edited)

7 hours ago, xX-SixtyCal-Xx said:

On the controls screen, green one at top right "Pedal Controls" change to X/Square buttons 

 

@mmax94 @Rednitro11 If you are stuck at the leaderboard after the race finished, press ColorP1 on the script menu. If you are stuck on the replay screen, press ColorP2 on the Replay/Next Race screen. (Dont press if it gets into the replay, wait for it to exit then press the button.)

Will try that thx.

Holy moly!!!! It worked! I selected the timing version and clicked color1 on the leaderboard since it took a good 3 seconds and nothing happend.

Then magic happend and im now 3 laps in the second race! xD

 

Thank you!

Edited by Rednitro11
Awesomenes happend
0

Share this post


Link to post
Share on other sites
23 minutes ago, InsaneInGame said:

Hey guys!

 

Thank you for an amazing AFK method. 😀 It's been working extremely well for me until a few hours ago.

So I've been running the AFK 0.7 which has worked well for me, no problems, and "earned" just over 

20.000.000 credits after about 32 hours of AFK'ing. But after I hit the 20 million credits mark

(20.000.009 million to be exact) I no longer get the credits I win after each race. It's strange because I

watch the entire 6 laps, everything is fine, clean racing, but then when the payout screen comes up,

it says 52.000 credits won, but they are not added to my credits total/account in the game.

 

If I just let the script continue, the same happens, 52.000 credits won, but they are not added to my total credits.

I'm stuck at 20.000.009 million. Is the 20 mill a cap with this method, has Sony/Polyphony Digital done

something? Any of you encountered the same issue? I've tried quitting the game, restarting the PS5,

but nothing is working, aka the credits doesn't get added anymore. 🤔

 

I hope somebody knows anything about what could be the issue here.

 

Best regards,

Tor Erik


You need to spend that money in order to gain more, 20mil is cap...

1

Share this post


Link to post
Share on other sites

Posted (edited)

I don't know what's up, but after 2 or 3 races, my car hits one of cars (Corvette) at the very beginning (when turning right into barrier) and starts spinning endlessly. I tried all version and it happens on all of them. I wonder if they changed something. Yesterday everything was working fine. Any ideas? 

Edited by Patrickosan
0

Share this post


Link to post
Share on other sites
11 minutes ago, Patrickosan said:

I don't know what's up, but after 2 or 3 races, my car hits one of cars (Corvette) at the very beginning (when turning right into barrier) and starts spinning endlessly. I tried all version and it happens on all of them. I wonder if they changed something. Yesterday everything was working fine. Any ideas? 

There is a turn delay variable that you can increase or decrease accordingly if you need

1

Share this post


Link to post
Share on other sites

Big thanks for making this, it must have been quite the challenge to set it all up and tweak it to work.

 

I found I needed a few tweaks to get it to work well for me on a PS4Pro, mainly some slightly longer delays in places eg between each right tap when scrolling through the championships.  I also set a slightly longer race time of 230k.

 

To get it working, I found it helpful to add a 'Log' method to the script, so I could see where it thought it was, and understand what was going wrong when it failed.

 

You can add the below to the bottom of the script, then you can add lines like Log("About to start race") at different parts of the script, and see where it's got to.  Then you need to leave a Notepad window open, and it'll write text there so you can see where it's got to.

 


GrabNotepad:
	WinGet, notepad_id, List, ahk_exe notepad.exe
	if (notepad_id, = 0)
	{
		MsgBox, Notepad not found
		return
	}
	Loop, %notepad_id%
	{
	  nid := notepad_id%A_Index%
	  WinGetTitle, title, % "ahk_id " nid
	  If InStr(title, "Notepad")
		break
	} 
	WinActivate, ahk_id %nid%
	return
	
Log(text) 
{
	gosub, GrabNotepad
	Send {Text}%text%`n
	gosub, GrabRemotePlay
}

You can remove the log once it's working well, but if you need to tweak it, I found it helpful.

4 minutes ago, Roanoke42 said:

There is a turn delay variable that you can increase or decrease accordingly if you need

 

Yeah, in the part of the script called 'Race:', there is a line like DllCall("Sleep", "UInt", 8200), meaning wait 8.2 seconds after starting, before starting to turn right.  Increasing or decreasing this number will change when it swerves right at the start.

 

I found it best to remove this line entirely, yes you ram another car from behind but it doesn't seem to result in tipping the car into a spin, so safest without perhaps.

0

Share this post


Link to post
Share on other sites

Septomor,

After V0.8, I connected my ps5 to a 4k tv, and changed the remote play computer screen resolution to 1920 * 1080 and the script has been working flawless ever since.

 

I had also tried to run it on a PS4 Pro with SSD with the same setup up and it did not work.

 

Thank you so much

0

Share this post


Link to post
Share on other sites

guys, in discord already has version 0.9, I tested it on ps4 slim and it's working perfectly for me, septomor put in his post the link to join the discord group.

Something I did that I don't know if it helped to work, I took my pc monitor off the hdmi and used it on vga, the first time doing this with version 0.9 it worked perfectly.

0

Share this post


Link to post
Share on other sites
8 hours ago, WhoWantsCake said:

After adjusting race length to 245000 and color_2_delay to 1000, I still get stuck in a replay loop and need to press right manually to get the script to continue.

 

I've added the 4 lines to this loop to press right before hitting X again and so far it's worked for 5 races or so in a row without getting stuck.

 

     loop {
         PixelSearch, x, y, %pix2x%-2, %pix2y%-2, %pix2x%+2, %pix2y%+2, %color_check2%, 20, Fast RGB
            If (ErrorLevel != 0) {
                 ControlSend,, {Right down}, ahk_id %id% 
                 Sleep, 200
                 ControlSend,, {Right up}, ahk_id %id% 

                 Sleep, 200
                 gosub, PressX
                 sleep %color_2_delay%
            }
            else{
                break
            }
    }

Thanks buddy, your changes are perfect for me, no more stuck on replay.

Race length and loop are now permanent compiled to a new EXE.

0

Share this post


Link to post
Share on other sites
2 hours ago, russelltang said:

Hi there, 

 

i have farm from $2m to $8m yesterday, but once i login again this morning, all my save seem back to 22-Mar-2022.
Anyone facing same issue with me?

Please follow the first post, the setting must use X button as accelerator.

 

the new script v0.8 had posted at P.14, you can follow @Septomor instruction to test. 

yeah i tried,

X as accelerator (not ok)

O as accelerator (ok)

X&O as accelerator (ok)

 

but still, it can't proceed to 2nd race

0

Share this post


Link to post
Share on other sites

Just a thought - can you randomize the menu selections? Instead of being immediate, randomize to take up to 0.5s to press X. If Sony/PD tracks for suspicious activity (as many fear), it'll totally throw them off the scent if no two input timings are strictly identical.

0

Share this post


Link to post
Share on other sites

first of all thank you sooo much for this its worked not flawlessly but well enough for me to be able to grind credits fairly well whilst sleeping.....accept for this morning when i woke up with the script trying to purchase credits for me, that terrified me, not too much though as im about to boot it back up before bed

0

Share this post


Link to post
Share on other sites

Updated to v8 and now after like 30 mins the script stops accelerating after the last turn then just completely stops working.. why?

0

Share this post


Link to post
Share on other sites

Just a heads-up if you use Asian/Japanese PS4 and wanna use the AFK script
Make sure you change the default accept/select button from circle to X, otherwise the script won't work since your Tomahawk didn't accelerate at all

0

Share this post


Link to post
Share on other sites
6 hours ago, lGenesisXl said:

Septomor,

After V0.8, I connected my ps5 to a 4k tv, and changed the remote play computer screen resolution to 1920 * 1080 and the script has been working flawless ever since.

 

I had also tried to run it on a PS4 Pro with SSD with the same setup up and it did not work.

 

Thank you so much

I use V0.701 pixel, which works very good with PS5. When I turn to PS4+SSD, it failed, since I don't know how to change the script, I use a triditional method: pluged in an external HDD and moved GT7 to it. Now it works fine on PS4+HDD, runs day and night without any problem. 

 

I would like to thank Septomor very much, you are doing a good job!

0

Share this post


Link to post
Share on other sites

Posted (edited)

@Septomor

 

Thanks for this mate, been running the 0.5 version as per original instructions on and off for a few days, it works pretty much flawless. You're doing God's work answering all these comments as well. I'm not saying it works for me so it should for everyone but a few simple things for you all, is to restart your laptop/PC after installing everything, follow the instructions to the letter, make sure you have a good stable connection as well. 

 

It may have been mentioned too, but using this method has popped the two online distance trophies too, I guess because it's using RP it thinks its playing online lol. 

 

Anyway. Thanks again 😎

Edited by funkyweed
0

Share this post


Link to post
Share on other sites

One more small tips for everyone, if you want to check if the script is stoped (car not running) remotely, just go to the GT official web site (up right corner, three small line, GT7, my page) from your mobile or PC, remember the miles roughly, and refresh the page after minutes, if the miles are going on bigger, then the script is running smothly.

 

 

0

Share this post


Link to post
Share on other sites

Posted (edited)

That's AWESOME Septomor, thank you so much for this script !!

You rock !!

Edited by Kephket
0

Share this post


Link to post
Share on other sites
36 minutes ago, Septomor said:

With an update coming out, I may decide to close the topic. Sorry for not staying on as much, a lot of work was put into the discord section to help people but if GT is serious about these updates, then it makes sense that these methods will not be needed.

Wait what update? What are you referring to?

0

Share this post


Link to post
Share on other sites

At least keep the links up for now man, I know you like GT7 downtime but that's going too far to emulate PD lol

0

Share this post


Link to post
Share on other sites

Posted (edited)

Still working as of patch 1.09, event order was not changed and still possible to use the Tomahawk for the event.

Edit: Didn't see any updates of the economy in 1.09 or any other event that would be worth while for the time being.

Edited by dotazured
1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.