Jump to content

HELP!!! Flying Fortress Trophy Bug in Dawn of Ragnarok


Recommended Posts

I cant unlock the flying fortress trophy in Dawn of Ragnarok on PS4. I tried a PS5 save, beginning the expansion from the beginning again and I tried to do the trophy on the PS5 and PS4 Pro Console but I cant unlock the trophy. I tried to fly on every Muspelheim Monolith and landing in the main area, on enemies and on top but the trophy wont unlock. Has anyone had the same problem or a solution?

Edited by Snorof88
Link to comment
Share on other sites

I got the Flying Fortress trophy now. I was save transfering my PS5 save into the PS4 Version and started playing with a save after I did the Flying Fortress Trophy on PS5 and the trophy didnt unlock. I then started a new save on PS4 before starting Dawn of Ragnarok and played to the point where I could do the trophy but it didnt unlock. I then tried not to play on PS5 Console instead I played on PS4 Pro Console and did it the same way at starting from the beginning of Dawn of Ragnarok till i got to the point to do the trophy but still it didnt unlock. I then decided to play again from my save after I got the platinum trophy more than 1 year ago and started at the beginning of Dawn of Ragnarok and tried at the point where I could get the trophy but it did not unlock. Now Finaly I thought of trying the same process again on the PS5 Version and transfer the save to the PS4 Version before I get to the point to fly to the Muspelheim Monolith and it Finaly Unlocked with this way of doing it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...