Jump to content

Slowdown glitch in the High Rift area


Doctor Completion

Recommended Posts

For those of you trying to complete the High Rift trophies, this glitch is awful, so I thought I'd describe it and share how to handle it.

 

The glitch:
If there are fast-moving enemies running around the lobby areas on randomly generated floors in the High Rift, there's a better than average chance that the gameplay will instantly stutter and lock up. Controller inputs are grossly delayed or stop working altogether; this includes using weapons or items in the action bar. The character will seize up in its movements too; you cannot walk, run, or jump. Panning with the camera in first-person mode gets delayed too. You can open the status menu, but that's about it. The glitch doesn't happen in the rooms with dispel obelisks or secret chests. It's going from room to room that's the problem. The glitch affected my runs randomly on floors 5 through 10. It didn't happen in the boss floors preceding Midway Rifts.

 

Which enemies are most likely to trigger this glitch?
Black Slimes are the most likely to cause the glitch. Occasionally, a Hollow Imp caused it too. My guess is that because the Black Slime can leap several frames really quickly, it'll "snag" the camera and cause the gameplay to stutter.

What should you do to counteract the glitch?
As hard as it is to do this, stop input button commands. If the screen appears to shake or stutter, don't press anything. It won't do any good. Oh, and yes, you'll helplessly watch your time tick down on the Rift Stability meter. It'll take several seconds, but the glitch will eventually work its way out. When your character appears to be idling normally, try moving again. Obviously, pop a Rift Stability scroll and perhaps make your way around the lobby to pick up as many Rift Stabilizing glyphs as you can. If you've done a pretty good job of memorizing most room layouts, you can get through them quickly and make up the lost time.

Are there any settings to prevent the glitch?
This isn't tested by any means, so take this with a grain of salt. Turn off any visual details like Bloom or Depth of Field. 

There are a couple of floors where Black Slimes roam freely. I proceeded slowly so that as few of them as possible appeared in the frame. Once I spotted one, I locked onto it and defeated it as quickly as I could. If the gameplay began stuttering at all, I simply stopped inputting anything. Since I was playing the Warrior, taking a hit or two wasn't an issue.

 

I'll be honest.
This glitch was frustrating enough for me to stop playing last night. I was already fried trying to memorize some of the obelisk rooms on the upper floors. I just felt like the glitch was happening more frequently, and I found only a couple mentions of it for Portal Knights players on PC. So, the best thing you can do is either:

 

  • Take a time-out.
  • Use the Map to warp back to Elysia and then return to the High Rift.

 

Good luck everyone!

  • Like 1
Link to comment
Share on other sites

  • 2 months later...

This glitch is annoying as hell. Not pressing any buttons, I'll try that, thanks.

Tried not pushing any buttons, didn't seem to make much of a difference to me, as to how long this glitch lasts. Since it usually lasts about 20 seconds in our reality, and the time within the game slows down a lot during the glitch, it's not so bad. Having a decent health regeneration helps with staying alive when under attack during such a glitch.

Over https://www.trueachievements.com/a276541/nosy-nellie-achievement they mention that it's the black jumping blobs that cause it, if they fall into the abyss. I can't really tell if that's the case.

 

Jeez, finally solved my own problem. I had to do three perfect runs. Turns out the other two weren't perfect after all. There is one room which has three chests, instead of two ... Ah, right, the trophy guide does mention it. That's good then, it properly explains which room it is as well.

Edited by de_digibeet
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...