Jump to content

Metropolis bug, any idea?


Recommended Posts

Hey so i am playing this game for the 2nd time to be able to get a platinum on it. Right now i am playing challenge mode and i am stuck on metropolis for some stupid reason :/


I go to the place where you get you're upgrade, go through all the way over the bridges and stuff untill the train station where i go left and on to the 2nd train. Kill all opponents on it while it is moving and then i jump off when it stopped. Go where you get the bot with the film (right door after train station). Took it, jumped down where the evulator is and go to my ship. I skipped the video if that would matter.


"Explore the rest of the city" is unchecked and i can't get a new planet with all other planets completed.

Any idea what might be the problem? I played this 3 times, left the planet and came back and played it again. No change.



Problem solved, game completed.

Tho this glitch is still active i was able to continue and complete the game.

The mission is still unchecked

Edited by anton1453
Link to comment
Share on other sites

Im pretty sure you haven't met Big Al yet or you haven't done Helga's Training Course. Either of those two initiates the ability to go to the next planet.


EDIT: Although, if you've played this game once already (Seeing as you are in Challenge Mode) then i don't see how you don't know where to go.

Edited by Jetstream Sam
  • Like 1
Link to comment
Share on other sites

Here is the thing tho, I have met big al got the upgrade went on the train and got the infobot. And I have done the training course. I talked to the fat girl robot and bought or got the slingshot and I now can take a car to the end in the beginning of the course. I have explored all of the map even taken all gold bolts. When I took the infobot I skipped cutscenes since I had already watched them once. Any idea?

Hey! Problem solved, forgot that I had the hydrodisplayser and I went got qwark and now I can progress in the story even though that metropolis is glitched. It is still unchecked even tho I am on umbilical now :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...