Jump to content

Quick question regarding headset sound on PS4


cronocyde

Recommended Posts

Hi everybody!

 

I need some help as I am unable to solve this problem on my PS4.

 

I have a 5.1 headset surround sound (Tritton Black Ops Limited Edition) and it's working perfectly on my PS3. When I plug it in my ps4 using an optical cable, whatever I'm doing, the sound always come from the HDMI cable in stereo. I have unplugged the optical cable and the sound was still coming through my headset, so it definitely coming from the HDMI source.

 

In the sound and settings, the output source is set to Optical Ouput, so I'm not sure if there's a problem with my PS4. My PS4 is plugged through a receiver via HDMI.

 

Anyone had this problem? On my PS3, I just had to switch the sound from HDMI to Optical and everything is working correctly.

 

Any help would be appreciated.

 

Thank you!

Link to comment
Share on other sites

I have the same thing on my turtle beach px5's.

Sound Output through hdmi whereas the cable runs through an optical output. Weird, since with both options i receive sound through the headset, just better when put on optical out.

I found it helps if you put these settings :

-sound optical out

-dolby digital (not dts)

-chat audio only through headset (weird, i know...)

-lower mic volume through controls (hold down ps button)

It should work ;)

My coop partners do still get an echo through their headsets, forcing me to sometimes use the ps4 standard mic. I personally don't hear an echo. I have no idea how to take care of this issue!!

I anyone knows how to solve these problems, much appreciated... Maybe it has to do with cable connections and setup?

  • Like 1
Link to comment
Share on other sites

Yes, do not check several options, only DD (for TB's at least, should work for you too). And don't put all audio through the headset, this will ruin the sound quality.

Sound is perfect for me, so hope this works for you, but i personally still have an echo problem, but this is a mic issue i think.

If you find a way to get the sound only through hdmi or optical, and not both, let me know, i kinda hope this takes care of my issues at once ;)

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...