Jump to content

New Trophy Cards won't display on WordPress post


TheMexiTV

Recommended Posts

Hello all !

I try to implement the new Trophy Cards on my forum (built with WordPress) and the image won't display.
It's the same thing with a friend, who is also on WordPress with the new Trophy Cards.
I try to put the "Direct URL" and the "HTML" but no sucess.

Do you know where the error can come from ?
PS : I'm not Premium but my friend is, and neither is working.

 

Image n°1 : On the publication area on WordPress, everything is good :
(table id is another plugin, not related to the problem)

1.PNG

 

Once is published, I have the "no image icon" :

2.PNG

 

Link to comment
Share on other sites

  • 3 weeks later...

For some reason the site alters the url of the image. Now the output for the image url comes up as https://i0.wp.com/card.psnprofiles.com/2/Mexi--.png?ssl=1 when it should be https://card.psnprofiles.com/2/Mexi--.png 

 

Not an expert on WP, but try to check if there are settings or plugins enabled that filter html code when a page or post is saved / published (can be debugged by disabling plugins one by one). Could also be some custom functions in the theme causing it so changing the theme can help pinpoint the issue. 

 

Did you try pasting the trophy card code on the "Texte" tab and saving the post/page (not sure if that affects anything in WP though)? Also if there's a possibility to use some kind of "full html" mode in the editor it could help.

Hope you can get the issue sorted out!

Link to comment
Share on other sites

  • 1 month later...
On 29/12/2016 at 0:08 PM, Eyjabria said:

For some reason the site alters the url of the image. Now the output for the image url comes up as https://i0.wp.com/card.psnprofiles.com/2/Mexi--.png?ssl=1 when it should be https://card.psnprofiles.com/2/Mexi--.png 

 

Not an expert on WP, but try to check if there are settings or plugins enabled that filter html code when a page or post is saved / published (can be debugged by disabling plugins one by one). Could also be some custom functions in the theme causing it so changing the theme can help pinpoint the issue. 

 

Did you try pasting the trophy card code on the "Texte" tab and saving the post/page (not sure if that affects anything in WP though)? Also if there's a possibility to use some kind of "full html" mode in the editor it could help.

Hope you can get the issue sorted out!

Hello !

 

Thank you for everything, your investigation help me a lot to solve the problem !

 

Indeed, it was a WordPress Plugin that was rewriting URLs for images.

The Plugin is JetPack and the function that was doing that is Photon.

You must disable it to let the image display correctly :

I2igjx.jpg

 

Many thanks again @Eyjabria :)

Edited by Mexi--
Link to comment
Share on other sites

On 2/2/2017 at 2:59 PM, Mexi-- said:

Hello !

 

Thank you for everything, your investigation help me a lot to solve the problem !

 

Indeed, it was a WordPress Plugin that was rewriting URLs for images.

The Plugin is JetPack and the function that was doing that is Photon.

You must disable it to let the image display correctly :

I2igjx.jpg

 

Many thanks again @Eyjabria :)

 

Awesome, you managed to fix the problem! I'm glad if my tips pointed you to the right direction.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...