Jump to content

Collectibles Trophy Bugged?


tam3rlanetv

Recommended Posts

Note sure if any other new players are going to come across this, so I thought id let everyone know in case.

I am running on the latest 1.09 patch I believe (the latest patch anyway) and I ran into an issue where I have collected all collectibles yet the trophy has not popped up.

 

Ive tried deleting save data, reinstalling, running the game again, no luck at all

Link to comment
Share on other sites

Completed the game and got the Platinum a few days ago & had no problems with any trophies.

Did you start the game on a previous patch? My play-through was exclusively on one patch, wonder if that's how the glitch happens?

Seems like your only option is another play-through. :(

Link to comment
Share on other sites

  • 3 weeks later...
On 09/02/2017 at 2:31 PM, ivangutjahr said:

Are you 100% sure that you have all type of collectibles? 

 

See this: 

 

 

Yeah, ive now done it, in the end i had to completely wipe all saves, and the install, then run through the game again, did it, and it randomly popped up so there must have been a bug somewhere.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...