Jump to content

Game won't load up on 'The Mountain That Fell' Mission


Recommended Posts

So 38 hours into this game and it no longer loads, its stuck on the loading screen!

Im on the mission 'The Mountain That Fell' and I was playing the game earlier for a few hours and it worked fine :/

I've tried deleting the application and re-installing and it just won't load :( anyone else got this problem?

Link to comment
Share on other sites

Try uploading your save to PS+ cloud or an external USB and deleting the save from your PS4. 


Will it load without your save being detected?


If so, the problem might be that your save got corrupted somehow... I don't know what the fix would be, but you've already tried re-installing the game...


Another thing you might try is rebuilding the database of your PS4s HDD. (This is basically a defrag like you would run on your PC.) Start the PS4 in safe mode and choose to rebuild the database. 


I didn't have any problems myself, so sorry that these are just guesses... 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...