Jump to content

Who's Laughing Now (Boss 3) Trophy Glitch Warning


Recommended Posts

TL;DR: Make sure that "Replays" are ON in the options, or the "Who's Laughing Now" trophy for the last boss won't unlock!

(Replays are On by default btw, so I guess this isn't really a common case)


So when I did the EU stack of this game yesterday, I tried to save a bit of time by setting Replays to Off before beginning the game.

Little did I know that this would cost me 1+ extra hour in the end.


When I did the last boss I went for the secret ending first, which didn't unlock the trophy for beating the last boss. I thought that was a bit strange, but I guessed those two "endings" are just mutually exclusive or whatever, so I did the last boss again the normal way: still nothing.

I retried several times, restarting and even reinstalling the game to no avail. So I deleted my save and did a quick speedrun of the levels (you can take all the secret exits if they're faster and change your ninja with triangle to complete some levels in seconds btw, this won't affect any trophies) and when I finally reached the last boss after an hour or so: still no trophy.

Then I realized that the only thing I did again was changing Replays to "Off". So I gave it one last try, switched that back to On, beat boss 3 for the 10th time or so and the trophy finally popped right there on the Replay screen!


I guess this last boss is a special case because it goes right to the credits if you don't have replays, skipping the trophy trigger or something.


otherwise fun little game and fairly easy trophies, recommended! ;)


  • Like 3
Link to comment
Share on other sites

7 hours ago, Smashero said:

"The Collector" is also slightly glitched: you need to have 15 collectibles at once, so do not go for "Upgraded!" before. It will not pop-up even if in "Stats" you have more than 15 found. 


oooh yeah, that was indeed easy to misunderstand. i fell for that in my first run of the game.

i actually ended up deleting my save and collecting the first 15 again, ugh. ;)

Link to comment
Share on other sites

  • 1 month later...
  • 3 months later...
  • 6 months later...
  • 3 years later...

i believe my game was buggy because yesterday in the same game session i was able to complete 2 entire worlds using all 3 ninjas by switching at any time, today i am able to only use one specific ninja per world, i think the game was designed only one ninja per world but for some reason I could use them all (and make gameplay easier)

Link to comment
Share on other sites

  • 4 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...