Jump to content

Doomsday Heist Glitched?


Recommended Posts

At the moment I start the last of the three new heists in GTA it will kick me and my friends out and saying there is a error, it happened around ten times so I quit for now. I tried leaving the game and starting up again but nothing worked for me. There aren't probably may people who are this far but if anyone comes at this point and have the same problem could you please let me know? 

Link to comment
Share on other sites

out of curiosity, have tried starting with all involved players in the facility setup room?...meaning no invites involved...i heard the invite process can be glitchy...


edit : just got the same glitch...the above info stands true...do not invite players to heist lobby...join up in heist planning room in leader's facility and start from there...players will automatically be in heist lobby...fixed our sync error...hope it helps... 

Edited by ProfBambam55
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...