Designer's Delight Glitch | Definite Solution

5 posts in this topic

I collected All Bricks but not unlock trophy.

I have unlocked all the bricks, plates, tiles and slopes.


You need your physical game.

Stop the internet connection. Set up the game. Do not install any updates.
It is not already installed because there is no internet connection. And re-collect.
Trophy will be opened.

Share this post

Link to post
Share on other sites

If you don't want to start over.. .then you'll need to purchase the DLC.


Thanks to a tip from you, (Nameless600) you will need the DLC as of 1.12 to get Designer's Delight. There's 9 plates between the two DLC packs that are required, even though they do not show up on the list if you don't own the packs.


Confirmed it testing with the wife today. She got all the base bricks, with no trophy. Then we downloaded the DLC and tried it, and it worked. (In fact both players got the trophy, not just P1)


Supposedly TT Games is working on a fix, but until then, you will need the DLC for the platinum.


Share this post

Link to post
Share on other sites

WOW So stupid. I stopped playing because i thought it glitched on me. I was just farming trouble makers for 5 hours while watching game grumps. So I have to spend money for it? I'm going to do it. Plus DLC won't be that expensive. Thank you very much



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.