GenoGi_32

Challenge Accepted Trophy

11 posts in this topic

Is it me or this trophy is not working for me? I told some of my friends with US region, to send the tower challenges and I didn't even got an alert or something like that, whenever I go to check Tower Challenger List, it's always empty. I even tried, creating an alternate account and sending a challenge to myself, but still nothing. It's so annoying. Maybe I am doing something wrong? Any advice? 

0

Share this post


Link to post
Share on other sites

What region are you, and what region is your game?

0

Share this post


Link to post
Share on other sites
On 12/23/2018 at 8:45 AM, Potent_Delusions said:

What region are you, and what region is your game?

 

US region, US game

0

Share this post


Link to post
Share on other sites

Actually you do not need any challenge from your friends. Just complete tower and send challenge to any of your friends. They do not need to be owner of the game. Just wait until the challenge expires (you should inform your friends they should not play it) and you will get the trophy. Note that you need to log in some time after it expires to earn it as it may be cancelled at all. Just check it regularly. 

Edited by RolandMate
0

Share this post


Link to post
Share on other sites

OP, I have the same problem and tried the same things you tried, including the friends not playing the challenge thing.

 

No luck for me. Have you figured anything out?

 

 

0

Share this post


Link to post
Share on other sites

Hey, as an update: 

 

It took me like two weeks, but I figured it out.

 

Go into your privacy settings, your message settings, your notifcation, all PS4 settings ever, and flip every single thing to the most ”open” setting. Just make your entire profile as wide open as possible. Available, allow, share, yes, open, etc. I don't know which setting it is, because I already had everything set to allow friends to send me stuff, but I just set everything I could to "everyone" instead of just friends and bam, the challenge went through.

 

I *think* it might be message settings? But I'm not sure.

1

Share this post


Link to post
Share on other sites
19 hours ago, Vladu24 said:

Hey, as an update: 

 

It took me like two weeks, but I figured it out.

 

Go into your privacy settings, your message settings, your notifcation, all PS4 settings ever, and flip every single thing to the most ”open” setting. Just make your entire profile as wide open as possible. Available, allow, share, yes, open, etc. I don't know which setting it is, because I already had everything set to allow friends to send me stuff, but I just set everything I could to "everyone" instead of just friends and bam, the challenge went through.

 

I *think* it might be message settings? But I'm not sure.

Thanks! it worked!

0

Share this post


Link to post
Share on other sites

Alright, man, congrats!

 

I'm happy we figured it out. It would have killed me to get all the ridiculous trophies and not Plat because of this tiny one.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.