FranciRoosters

Dressed for Success Glitched?

10 posts in this topic

Just downloaded and played through the last DLC. Did the story mission, finished the tomb, did score and time attack, yet I can’t unlock the last trophy because the outfit doesn’t seem to be available. I managed to unlock the DLC skill and the weapon, but the outfit is greyed out. I relaunched the game twice and tried at a different camp. Nothing. Ideas? Is anyone experiencing the same? Thanks!

Edited by FranciRoosters
0

Share this post


Link to post
Share on other sites

Equip it directly from the challenge tomb (Menu). Worked for me...

0

Share this post


Link to post
Share on other sites

Not unlocking as well, finished the mission and time/score challenge, equiped the outfit/gun, but not unlocking.

Tried to do this in-game as via challenges, but nothing's working..

0

Share this post


Link to post
Share on other sites
27 minutes ago, YeyMuffins said:

Not unlocking as well, finished the mission and time/score challenge, equiped the outfit/gun, but not unlocking.

Tried to do this in-game as via challenges, but nothing's working..

there are 2 new outfits and 2 new guns. I didn't get the tropy at first either. Just try every combination. Trophy did unlock eventually ...

1

Share this post


Link to post
Share on other sites

You can't equip it while you're inside Paititi, because only a select few outfits are available in the village. You need to fast travel to a camp outside to equip it.

Edited by madbuk
0

Share this post


Link to post
Share on other sites
3 hours ago, madbuk said:

You can't equip it while you're inside Paititi, because only a select few outfits are available in the village. You need to fast travel to a camp outside to equip it.

tried that, but didn't work

0

Share this post


Link to post
Share on other sites
23 hours ago, Aranui_Savyron said:

there are 2 new outfits and 2 new guns. I didn't get the tropy at first either. Just try every combination. Trophy did unlock eventually ...

Worked, thanks!

0

Share this post


Link to post
Share on other sites

This stumped me for a while too. In the end I travelled to that small boxed area in the top left corner of the map and that worked. 

0

Share this post


Link to post
Share on other sites

Amazing that this game still forces you to use certain outfits in certain regions. Found that really fucking stupid. Everytime i had to talk to the mowgli kid who think he is king i had to put one outfit on, and that outfit gave worthless shit bonuses. So 20 seconds later i had to equip a decent outfit again, and rinse and repeat several times during the game just so you could talk to the biggest asshole in the game for 10 seconds.

1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.