Septomor

Automated BTs Scripts (Arumat + Edge 30k and others)

38 posts in this topic

17 hours ago, boomgo99 said:

I have not been able to get it to work.  It stays in an infinite loop.  Meracle plays the ocarina but in battle he only heals (Edge) but does not attack.  What am I doing wrong?

Alright good news is I've edited them all and tested all but the 255 drops ones, but those should work as well. I tested it from PS5 but the application is the same for PS4 if you are using that, so it should still work. The dropbox link is the same, so let me know how it goes, thanks for letting me know. 

 

Dropbox

2

Share this post


Link to post
Share on other sites
4 hours ago, Septomor said:

Muy bien, la buena noticia es que los he editado todos y probado todos menos los de 255 gotas, pero esos también deberían funcionar. Lo probé desde PS5, pero la aplicación es la misma para PS4 si la estás usando, por lo que aún debería funcionar. El enlace de Dropbox es el mismo, así que avíseme cómo va, gracias por hacérmelo saber. 

 

Dropbox

Now it works!  Thank you so much for your hard work and for bothering to fix it, I appreciate it.😉

0

Share this post


Link to post
Share on other sites

After the news of yesterday about the new game, got very hyped now for work on this plat, after a long break lol and now i found this👀 simply awesome thank you.

0

Share this post


Link to post
Share on other sites

Any testimonials of people using this? I am hesitant to try it, I am already halfway done (my second stack) so I feel kind of committed. The ology drops would be clutch, I don't mind Arumat kill farming as much.

0

Share this post


Link to post
Share on other sites
1 hour ago, Bos10George said:

Any testimonials of people using this? I am hesitant to try it, I am already halfway done (my second stack) so I feel kind of committed. The ology drops would be clutch, I don't mind Arumat kill farming as much.

What would you like to know about it? It's not perfect in that you could theoretically do it by yourself faster (but probably not much faster), it just allows you to farm without having to pay attention, while sleeping or whatever. All the -ology drops when run will do the following

1. Using ocarina to resummon enemies

2. Wait for battle

3. Spam an attack 

3a. While spamming check coordinates in ps remote play window for a colored pixel that only appears in battle

4. Battle ends spam continue

5. Repeat

1

Share this post


Link to post
Share on other sites

WD for Sarah seems a bit of a pain. I normally use the celestial ship on Lemuris. There is a harpy for her flying kills there as well.

 

0

Share this post


Link to post
Share on other sites
On 8/12/2021 at 0:25 AM, Septomor said:

Alright good news is I've edited them all and tested all but the 255 drops ones, but those should work as well. I tested it from PS5 but the application is the same for PS4 if you are using that, so it should still work. The dropbox link is the same, so let me know how it goes, thanks for letting me know. 

 

Dropbox

Hi Septomor,

 

Thanks a bunch for this. I'm looking forward to trying this out.

 

The new Dropbox link doesn't seem to work, but the one at the start of the thread seems to have the files from 8/11/2021 so I think I'm okay. I'm still having the issue with the ocarina loop though, and I'm guessing AHK is having trouble finding the pixels it needs to know whether it's in battle and all that. Do you know if another remote play update messed that up?

 

I'm a forum novice so I can't figure out how to edit, but the issue was that my default screen resolution wasn't 1080p on my Mac since I'm running Windows on that, so once I changed it it was able to find the appropriate pixel. However now it seems to be stuck in the use menu and can't use the ocarina....

Edited by DentistQuaid
Adding additional info
1

Share this post


Link to post
Share on other sites

Sorry this post is a dumpster fire but hopefully this can help somebody else as well:

 

TL;DR

*Make sure your screen resolution is 1920 x 1080 if you're weird like me, so that the program can find the pixels it needs to find to do its thing.

*I wouldn't advise pausing the script and trying to restart it, that's what seemed to mess my script up... Best to just turn it off and try it again if you need to.

 

0

Share this post


Link to post
Share on other sites
6 hours ago, DentistQuaid said:

Hi Septomor,

 

Thanks a bunch for this. I'm looking forward to trying this out.

 

The new Dropbox link doesn't seem to work, but the one at the start of the thread seems to have the files from 8/11/2021 so I think I'm okay. I'm still having the issue with the ocarina loop though, and I'm guessing AHK is having trouble finding the pixels it needs to know whether it's in battle and all that. Do you know if another remote play update messed that up?

 

I'm a forum novice so I can't figure out how to edit, but the issue was that my default screen resolution wasn't 1080p on my Mac since I'm running Windows on that, so once I changed it it was able to find the appropriate pixel. However now it seems to be stuck in the use menu and can't use the ocarina....

 

TL;DR

*Make sure your screen resolution is 1920 x 1080 if you're weird like me, so that the program can find the pixels it needs to find to do its thing.

*I wouldn't advise pausing the script and trying to restart it, that's what seemed to mess my script up... Best to just turn it off and try it again if you need to.

Sorry to hear, hopefully changing it helped and everything runs smoothly now. I don't remember how pausing worked exactly or why it might mess things up. It's possible that I forgot key states in AHK or something. Strange that the link didn't work, I thought they were identical but maybe not. Thanks for the help!

0

Share this post


Link to post
Share on other sites

I think part of it was also that it seemed to mysteriously set the delaykey value back to 100 after I thought I had changed it to 150 haha, it worked great overnight and a couple times this morning I caught it stuck in Meracle's name change menu so I changed that again and hopefully everything will go back to perfect. Thanks again for these scripts, super helpful and well done

0

Share this post


Link to post
Share on other sites

@Septomor Hey man, I hope you can help me if it doesnt bother you too much. Ive been grinding some battles and wanted to try these scripts while I was working or sleeping but so far none of them seem to work correctly. I have tried both the colusseum and Arumat 30k kills one and both get stuck in loops. Changing the key delay didnt help. I think its because it isnt detecting the sreen propperly. i have even tried changing my resoultion to 1920 x 1080 but the scripts still wont work.

0

Share this post


Link to post
Share on other sites
21 hours ago, sebastian003Peru said:

@Septomor Hey man, I hope you can help me if it doesnt bother you too much. Ive been grinding some battles and wanted to try these scripts while I was working or sleeping but so far none of them seem to work correctly. I have tried both the colusseum and Arumat 30k kills one and both get stuck in loops. Changing the key delay didnt help. I think its because it isnt detecting the sreen propperly. i have even tried changing my resoultion to 1920 x 1080 but the scripts still wont work.

 

Hey, sure thing. Can you describe when/how the loop starts failing? Is it during the battle or menuing or somewhere else? Does it work for awhile then stop working or it just doesn't work at all? I don't have the game downloaded so it would take me a couple hours to redownload and test things out if we need to. 

 

You're probably right that it's failing by not detecting the right parts of the screen. I wanted to create a color picker application at some point so people could configure the setup themselves but never got around to it. If I remember correctly, I set it up to check for the ENEMY yellow color in the top left corner, once that disappears then the battle ends, then checked for something near the gem board on the right side to disappear to show the transition to the overworld to start Meracle's menuing. If either of these fail then it'll get stuck in a loop probably. 

 

One potential thing to check would the color of your computer's display, but I think that's too much work for users to configure. 

0

Share this post


Link to post
Share on other sites
On 22/1/2022 at 2:39 PM, Septomor said:

 

Hey, sure thing. Can you describe when/how the loop starts failing? Is it during the battle or menuing or somewhere else? Does it work for awhile then stop working or it just doesn't work at all? I don't have the game downloaded so it would take me a couple hours to redownload and test things out if we need to. 

 

You're probably right that it's failing by not detecting the right parts of the screen. I wanted to create a color picker application at some point so people could configure the setup themselves but never got around to it. If I remember correctly, I set it up to check for the ENEMY yellow color in the top left corner, once that disappears then the battle ends, then checked for something near the gem board on the right side to disappear to show the transition to the overworld to start Meracle's menuing. If either of these fail then it'll get stuck in a loop probably. 

 

One potential thing to check would the color of your computer's display, but I think that's too much work for users to configure. 

Sorry for the late response, I have managed to get them to work by fixing some color options on my screen, Thanks for the reply though.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.