KnightAtomic

Can't seem to join private games.

13 posts in this topic

This happens a lot, if I try and join public games then there is no problem but as soon as I try and join one of my friends games or invite them over for a game then nothing works at all. I honestly have no idea what could be wrong. I am a plus member and my internet at home is working fine, as I said it is only when I try to play a private game and only on the PS4.
So far I have tried:

Crash team racing
Conan exiles
Watchdogs 2

I don't know why it does this, again I can play with friends fine if we happen to be in the same game but I can't invite them. is this a known problem? 

EDIT: My NAT connection is NAT3 I have no idea if that is good or bad when related to my case or what I should have or if I can change it.

Edited by KnightAtomic
0

Share this post


Link to post
Share on other sites

Check your NAT internet level, if it's not that perhaps some router configurations.

1

Share this post


Link to post
Share on other sites

So ok anything I need to be on the lookout for when it comes to router settings? Also how do I check NAT levels, sorry if this just became a costumer service call.

0

Share this post


Link to post
Share on other sites

just do a standard internet connection test on your playstation and it'll give you your nat type there.

0

Share this post


Link to post
Share on other sites
Just now, Leenewbe said:

was just trying to find something to link, saved me a search. 1f44d.png

I'm a Google Master ;)

 

It's all in the search terms.

0

Share this post


Link to post
Share on other sites

So I checked my NAT connection and it looks like I have NAT3, again I have no idea if this is good or bad.

0

Share this post


Link to post
Share on other sites
15 minutes ago, KnightAtomic said:

So I checked my NAT connection and it looks like I have NAT3, again I have no idea if this is good or bad.

NAT 3 is the worst one you can have, because then you can only join other people who also have NAT 3. NAT 2 is the best one with NAT 1 being the middle ground. To get out of this, you need to put your console into your Router's DMZ so it will be placed outside of the Firewall and allowed to communicate freely with PSN.

1

Share this post


Link to post
Share on other sites

So I need to connect it directly to the router? I guess I am out shopping for a network cable. Also thanks for the tips. <3

Edited by KnightAtomic
0

Share this post


Link to post
Share on other sites
9 minutes ago, KnightAtomic said:

So I need to connect it directly to the router? I guess I am out shopping for a network cable. Also thanks for the tips. <3

If that doesn't give you NAT 2, then you will have to manually login to your Router and fiddle around with the DMZ settings.

0

Share this post


Link to post
Share on other sites
1 minute ago, HuntingFever said:

If that doesn't give you NAT 2, then you will have to manually login to your Router and fiddle around with the DMZ settings.

I honestly think I will try that first. Thanks either way, this has been driving me crazy for months, maybe now I can actually fix it.

Edited by KnightAtomic
1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.