Jump to content

The lightning bringer


Recommended Posts

I got it when I was running around randomly. Everything I read said I should have gotten it much earlier but it did eventually show up while I was by the arena. 

Also I should add I have terrible internet so I play disconnected from psn because the system hangs on the trophy tab if I don’t. I had just reconnected to psn when they popped up. So I don’t know if being online had anything to do with it or not. 

Link to comment
Share on other sites

  • 1 month later...

Same problem, neither boss will appear in my game.  Clearly a bug that Ubi-$$$ can't be bothered to fix because it's part of the free DLC.  I know for a fact that I explored these two locations very early in the game before I was "supposed" to be there, so I'm guessing that's why the game crapped the bed.  Have blue icons that allow fast travel to the locations, but nothing is there.  Nothing ever appeared in my quest log at any point.  Checked all boards anywhere near the locations, nothing.  Checked notice board on my ship, nothing.  Cleared all side quests anywhere near the locations, nothing.  Character is level 90+, long since completed main story, fully upgraded spear, all 4 mythical creatures, got Platinum, finished Legacy of the First Blade DLC, finished every other Lost Tales of Greece trophy, and started Atlantis DLC.  Tried deleting and reinstalling entire game, took nearly two hours, still broken.  Bravo Ubi-$$$, bravo!!  

Link to comment
Share on other sites

On 5/12/2020 at 3:22 AM, Narniak said:

Same problem, neither boss will appear in my game.  Clearly a bug that Ubi-$$$ can't be bothered to fix because it's part of the free DLC.  I know for a fact that I explored these two locations very early in the game before I was "supposed" to be there, so I'm guessing that's why the game crapped the bed.  Have blue icons that allow fast travel to the locations, but nothing is there.  Nothing ever appeared in my quest log at any point.  Checked all boards anywhere near the locations, nothing.  Checked notice board on my ship, nothing.  Cleared all side quests anywhere near the locations, nothing.  Character is level 90+, long since completed main story, fully upgraded spear, all 4 mythical creatures, got Platinum, finished Legacy of the First Blade DLC, finished every other Lost Tales of Greece trophy, and started Atlantis DLC.  Tried deleting and reinstalling entire game, took nearly two hours, still broken.  Bravo Ubi-$$$, bravo!!  

I'm not quite this far along- I have the dlc to complete.  But I'm seeing the same thing.  Reinstalled the game since a few people said that worked and still able to fast travel but no boss.  I also went to these locations early in the game and I'm wondering if that is what broke it.  

Link to comment
Share on other sites

I suggest anyone having issues report it here:

 

https://forums.ubisoft.com/showthread.php/2212355-Arges-and-Steropes-cyclops-are-not-spawning-and-I-m-well-ahead-in-the-story/page2

 

It's doubtful Ubisoft will do anything at this point but at least their support reps are listening. I have the platinum now and all the additional feats DLC complete.  Both Cyclops will still not show even though I can fast travel.  I've never seen it in my log or a message board.  I also deleted the game and reinstalled.  The only other thing to do is hope it randomly spawns as I play through the paid DLC. 

Link to comment
Share on other sites

On 5/12/2020 at 5:22 AM, Narniak said:

Same problem, neither boss will appear in my game.  Clearly a bug that Ubi-$$$ can't be bothered to fix because it's part of the free DLC.  I know for a fact that I explored these two locations very early in the game before I was "supposed" to be there, so I'm guessing that's why the game crapped the bed.  Have blue icons that allow fast travel to the locations, but nothing is there.  Nothing ever appeared in my quest log at any point.  Checked all boards anywhere near the locations, nothing.  Checked notice board on my ship, nothing.  Cleared all side quests anywhere near the locations, nothing.  Character is level 90+, long since completed main story, fully upgraded spear, all 4 mythical creatures, got Platinum, finished Legacy of the First Blade DLC, finished every other Lost Tales of Greece trophy, and started Atlantis DLC.  Tried deleting and reinstalling entire game, took nearly two hours, still broken.  Bravo Ubi-$$$, bravo!!  

Update:  Finished all the Atlantis DLC including all trophies, then started a NG+ against my better judgement.  Made sure to not to go anywhere near the gold "?" marker when doing the first visit to the island for the spear upgrade (I'm guessing that's what corrupted my game file for eternity in the first playthrough).  Took about 10 hours to play through the main story all the way to the end of Sequence 4, hoping the 2 quests would finally appear, but nothing.  Immediately upon completely Sequence 4, every other "Lost Tales of Greece" marker instantly appears on the map and in my quest log.  No Steropes or Arges though, those two simply don't exist in my game.  Checked the board on my ship and the boards on land near the islands, nothing.  Tried traveling to the gold "?" location on each island, but they simply turn to the blue marker enabling fast travel like the last playthrough.  No bosses are there, and no quest markers or log for the two quests have ever existed in my game.  That's it, I'm done with this trash game.  Uninstalling until maybe there is a patch someday when Ubi-CASH decides to give a damn about their customers.  I checked the Ubi-CASH site forum, and it is filled with numerous posts from people having this same issue.  No help from Ubi-CASH.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...