kiseiju68

Polychoron

9 posts in this topic

How many Polychorons does it take to get a "Major Artifact" to level 10?

 

Tanks!

0

Share this post


Link to post
Share on other sites

9 to 10 only it's 65 polychoron, so I think you need something like 150 of them more or less.

0

Share this post


Link to post
Share on other sites
1 hour ago, cedom02830 said:

9 to 10 only it's 65 polychoron, so I think you need something like 150 of them more or less.

 

Thanks!

0

Share this post


Link to post
Share on other sites
On 9/17/2020 at 3:29 PM, TizonaES said:

I used way more than 150. I had around 250 iirc and I ended with 7 left after upgrading it.

257 is supposedly the magic number.  They are supposedly actually gifting everyone who logs in before Oct 1st 250 Polychoron and 500 Uru for all the issues that they have had.

0

Share this post


Link to post
Share on other sites
8 minutes ago, Snake2410 said:

257 is supposedly the magic number.  They are supposedly actually gifting everyone who logs in before Oct 1st 250 Polychoron and 500 Uru for all the issues that they have had.

It would be cool if this even worked as for me and many others the game is not giving me these lol.

0

Share this post


Link to post
Share on other sites
3 minutes ago, Lightsp33d1987 said:

It would be cool if this even worked as for me and many others the game is not giving me these lol.

Really?  Haven't heard of that one.  My only issue with assignments was the villain sectors not refreshing every day so I only got to run through each one like once before they stayed marked done evey day.

0

Share this post


Link to post
Share on other sites
1 minute ago, Snake2410 said:

Really?  Haven't heard of that one.  My only issue with assignments was the villain sectors not refreshing every day so I only got to run through each one like once before they stayed marked done evey day.

Yeah there is a lot of us with this problem it seems as plenty moaning on Twitter about it.

0

Share this post


Link to post
Share on other sites
8 minutes ago, Lightsp33d1987 said:

Yeah there is a lot of us with this problem it seems as plenty moaning on Twitter about it.

I haven't downloaded the patch or logged in at all since last night so I'm not even sure it's working for me either. 

 

I misread your post and though you ment it wasn't giving you any for the past few weeks.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.