Roden124

Macro or: How I Learned to Stop Worrying and Love the Grind

71 posts in this topic

On 11/25/2020 at 8:23 AM, melodicmizery said:

after remote play updated for ps5 i get a "injection failed" message when i open ps4 macro. this happening to anyone else?

edit i fixed it i think, i went into the xml setting and marked false for auto inject

 

Hey Bro, Can you tell me how to do it on PS5? I have only this missing trophi 

0

Share this post


Link to post
Share on other sites
7 hours ago, Pelon24_CR said:

 

Hey Bro, Can you tell me how to do it on PS5? I have only this missing trophi 


i dont have a ps5, nor do i have tony hawk. my macro stopped working and i was searching forums for anyone who had been using them. i then looked into my macro folder, opened up settings1.xml and setting 2.xml and marked auto inject to false to get the program to startup.

im not exactly sure what your asking, if i can help you start the macro?, set the macro up?, or use it on tony hawk?

you need remote play
you need your console to be activated as primary
you start remote play on a pc, use a usb cord to plug your controller in and start remote play

start the ps4 macro

load the macro file that the guy has on the first page, or create your own. to create your own there is tutorials on youtube that can explain it better then me writing it.

0

Share this post


Link to post
Share on other sites
On 11/23/2020 at 0:01 PM, Alexgaara said:

Okay, following @TurtlePM new video, you can download the 72K xp per hour macro here.

 

Setup:

Put the 900 special on :down::up::circle:

Activate "Perfect Manual Balance" & "Always Special" & "No Bails" & "Double Base Score" under Options > Games Mods.

Load the map via Skate Tours > THPS > Downtown.

Manually reload the map 2-3 times (because those loads takes longer than the following ones, you can skip this step but the 2-3 first tries won't work properly)

Once that's done, end the session, highlight "Retry Level" and launch the macro.

 

It's generous pointwise, if every tricks gets through you're looking at 1.6 mil, never failed once so far (just 10 minutes of testing though), and even if it does it'll correct itself by the next run.

 

Care to enlighten me I don't know what I'm doing wrong. I downloaded the software and got it running but it doesn't seem to work properly. I followed all steps but all my character does is spam nose grab and manuals never getting more than 100k score. I'm running that downtown 72k macro and following the instructions?

0

Share this post


Link to post
Share on other sites
4 hours ago, amebapiko said:

 

Care to enlighten me I don't know what I'm doing wrong. I downloaded the software and got it running but it doesn't seem to work properly. I followed all steps but all my character does is spam nose grab and manuals never getting more than 100k score. I'm running that downtown 72k macro and following the instructions?

 

That's weird... Just tested it again to be sure, and even though it took like 10 runs to get running (because the game kept taking ages to load), after that it's all good, no nosegrab in sight.

Are you definitely sure you put the 900 special on :down::up::circle: ?

What's your network settings like? My pc is connected on a switch via Ethernet, the switch to a router, and the PS4 is on said router. If you're in WiFi it might be dropping packets resulting in your issues (though if it was that I think you'd still see some 900 from time to time, which is not the case).

Is there anything else running on your PC that could be using up resources? The macro software doesn't require much, but seeing the amount of data it sends per second, if something else is going around in the background you could end up having issues because of this.

0

Share this post


Link to post
Share on other sites
4 hours ago, Alexgaara said:

 

That's weird... Just tested it again to be sure, and even though it took like 10 runs to get running (because the game kept taking ages to load), after that it's all good, no nosegrab in sight.

Are you definitely sure you put the 900 special on :down::up::circle: ?

What's your network settings like? My pc is connected on a switch via Ethernet, the switch to a router, and the PS4 is on said router. If you're in WiFi it might be dropping packets resulting in your issues (though if it was that I think you'd still see some 900 from time to time, which is not the case).

Is there anything else running on your PC that could be using up resources? The macro software doesn't require much, but seeing the amount of data it sends per second, if something else is going around in the background you could end up having issues because of this.

 

Thanks for the reply, yeah I made a huge mistake and put the 900 on :up::down::circle: . So I tried now and it's spamming 900s as it should, first run it reached 1.9mil 😄

0

Share this post


Link to post
Share on other sites

Sadly I got so many problems with remote play and also my PC. I can probably get an hour stretch of it working if I'm seriously lucky. The major problem now is the macro running too slow (so it doesnt work). Before I was getting disconnected from remote play too much and I have a mouse clicker to reconnect it, but currently struggle to get the macro even running at all. It's infuriating, if my macro isn't working the remote play will function flawlessly, when my macro works my remote play will disconnect every minute 😬

Edited by amebapiko
0

Share this post


Link to post
Share on other sites

Eh that sucks :(

 

Have you tried by running your PC in safe mode with network support? It would load the bare minimum and leave you with more resources to focus on the remote play & macro.

Not sure if it works though, I haven't personally tried it, and the remote play software might not work because of missing services and stuff...

Edited by Alexgaara
1

Share this post


Link to post
Share on other sites

just wanna thank all you guys who found out about this "exploit" and uplaoded the macros and all that! with the downtown run it went pretty fast from 77 to 100, i think it was a lil under 5-6h!
thank you!

0

Share this post


Link to post
Share on other sites

Anyone else having issues with the 75k downtown macro? I can get it to work but most runs I very rarely even can get over 100 combined XP.  I can see the macro pulling off manuals and 900s but it seems the timing stuffs up and means it’s either not a combo or skater hits something and cancels out combo.
 

Thinking there is some sort of input lag that throws off the run, but I am running both the ps4 and laptop over ethernet without any visible strain. Inputs seem fine when navigating through the game menus etc it’s only when the macro is running.

 

** update **
While I couldn’t get the 72k downtown macro to work, I managed to use the 36k p.a skate park macro as a work around. I reduced the score challenge to 100k to ensure I still win if the combo does not always work, most of the time I still pull off 900k-1m in a run to get the 300XP. Using this method I got to lvl 100.

Edited by mipdii
0

Share this post


Link to post
Share on other sites

Hey guys,

first of all, thank you for your awesome work!

Having done all of the actually hard stuff, I am now down to this extremelyy tedious, shitty, useless grind at the end...

Here's my problem though: I cannot seem to get PS4Macro to work properly...

I am using the updated PS-remote app, the 0.52 of PS4macro and am running both as administrator... Using a lan cable connection and I even disabled my firewall and other programs temporarily as to exclude all other issues... Ps4MAcro still not running properly even after several restarts of both my pc and PS4Macro... It is starting slowly, frames moving slowly if at all... Very erroneous... Any ideas or any help you could give me? I would REALLY appreciate it, thanks!

 

0

Share this post


Link to post
Share on other sites

@mipdii Sorry to @ you, but I was wondering what PS4 you had. I've done those macros with a Pro, and on the downtown macro I forgot to wait at the start, meaning anyone with longer (or even shorter) loading times than mines would probably have their run get those kinds of issues (whereas the 36K macro I waited a couple seconds at the beginning to be more lenient towards slower loading times).

Were you getting the gap at the beginning every time? Cause you said sometimes your skater was hitting things, while it shouldn't have, so I'm guessing loading times were messing this up.

 

@PO_1984 From what you said I'd think your issue is CPU related, but I might be wrong.

Have you tried it in safe mode (with network enabled)? What's your CPU? If it's a series that was affected by the meltdown/spectre issue, you could try to disable the patch see if it helps.

https://www.reddit.com/r/intel/comments/7ufh3b/uninstall_all_meltdownspectre_windows_updates/

You could also give a higher priority to the PS4macro program to see if it helps.

https://www.tenforums.com/tutorials/89548-set-cpu-process-priority-applications-windows-10-a.html

0

Share this post


Link to post
Share on other sites
5 hours ago, Alexgaara said:

Sorry to @ you, but I was wondering what PS4 you had. I've done those macros with a Pro, and on the downtown macro I forgot to wait at the start, meaning anyone with longer (or even shorter) loading times than mines would probably have their run get those kinds of issues (whereas the 36K macro I waited a couple seconds at the beginning to be more lenient towards slower loading times).

Were you getting the gap at the beginning every time? Cause you said sometimes your skater was hitting things, while it shouldn't have, so I'm guessing loading times were messing this up.


I tried with both a pro and og ps4 both had the same issue with the downtown macro. Most of the time I was missing the kicker gap at the start of the run, but also the macro would do the jump and very rarely actually pull off the 900.

 

I did think that it might have something to do with loading times so I did a few runs where I tried to delay the start of the script but it didn’t work.

0

Share this post


Link to post
Share on other sites
17 hours ago, mipdii said:


I tried with both a pro and og ps4 both had the same issue with the downtown macro. Most of the time I was missing the kicker gap at the start of the run, but also the macro would do the jump and very rarely actually pull off the 900.

 

I did think that it might have something to do with loading times so I did a few runs where I tried to delay the start of the script but it didn’t work.

 

Ah okay, I probably ended up doing the Downtown macro with faster inputs than the Skate Park one; resulting in this kind of issues if the ps4macro program skips inputs or there's some I/O issue.

Thanks for the feedback, sorry to see you had issues with it, but still good to know that the Skate Park one can be a workaround if Downtown doesn't work.

0

Share this post


Link to post
Share on other sites

heya everyone i downloaded ps4 marco winzip but there is no program in it its just a bunch of files where did i go wrong?

0

Share this post


Link to post
Share on other sites
On 03/01/2021 at 6:45 AM, Cats said:

heya everyone i downloaded ps4 marco winzip but there is no program in it its just a bunch of files where did i go wrong?

 

You sure you downloaded the right one? You might've got the uncompiled one...

It's on this page, the "PS4Macro0_5_2.zip" (direct link). Unzip it, then you just start PS4Macro.exe

0

Share this post


Link to post
Share on other sites
On 1/7/2021 at 11:28 AM, Alexgaara said:

 

You sure you downloaded the right one? You might've got the uncompiled one...

It's on this page, the "PS4Macro0_5_2.zip" (direct link). Unzip it, then you just start PS4Macro.exe

AH! that was the correct file i was looking for! thank you!

0

Share this post


Link to post
Share on other sites

Hey,

yesterday i finished the level 100 trophy with the PS4 Macro on my PS5 and it worked pretty well with the 72k Downtown macro.

It didn't work with the PS5 controller, so i had to take the "old" ps4 controller for remote play in order to make the macro-tool work. 

 

The first kicker-gap-jump only worked the first time i started the level. I think that had to do with the shorter loading times on PS5.

Nevertheless in 99% of the rounds i was getting the full amount of XP and the levels from 72 to 100 was over in about 6 hours.

 

Thank you for your awesome work. I wouldn't had do it without the macro.

 

Greetings, Mraz

1

Share this post


Link to post
Share on other sites
On 23. 11. 2020 at 6:01 AM, Alexgaara said:

Okay, following @TurtlePM new video, you can download the 72K xp per hour macro here.

 

Setup:

Put the 900 special on :down::up::circle:

Activate "Perfect Manual Balance" & "Always Special" & "No Bails" & "Double Base Score" under Options > Games Mods.

Load the map via Skate Tours > THPS > Downtown.

Manually reload the map 2-3 times (because those loads takes longer than the following ones, you can skip this step but the 2-3 first tries won't work properly)

Once that's done, end the session, highlight "Retry Level" and launch the macro.

 

It's generous pointwise, if every tricks gets through you're looking at 1.6 mil, never failed once so far (just 10 minutes of testing though), and even if it does it'll correct itself by the next run.

Thanks for this macro, unfortunately I get inconsistent loading times on PS4 Pro and sometimes I get a gap and other times I don't, not sure if there is anything I can do from my side to always get 1.6mil score instead of 400k/900k which I usually have. 

 

EDIT: Looks like it's working now after I picked Officer instead of my created skater, strange 

Edited by Matush_SVK
1

Share this post


Link to post
Share on other sites
On 24/01/2021 at 4:48 PM, Matush_SVK said:

Thanks for this macro, unfortunately I get inconsistent loading times on PS4 Pro and sometimes I get a gap and other times I don't, not sure if there is anything I can do from my side to always get 1.6mil score instead of 400k/900k which I usually have. 

 

EDIT: Looks like it's working now after I picked Officer instead of my created skater, strange 

 

Hey, thanks for the feedback, that's pretty weird indeed, but I'm glad you found this trick to make it work.

Have you tried it again, see if you had the same issue and Officer Dick made it work again?

I'll mention your workaround in the post ;) 

0

Share this post


Link to post
Share on other sites
2 hours ago, Alexgaara said:

 

Hey, thanks for the feedback, that's pretty weird indeed, but I'm glad you found this trick to make it work.

Have you tried it again, see if you had the same issue and Officer Dick made it work again?

I'll mention your workaround in the post ;) 

Definitely works with Officer Dick, I let it run for around 10 hours and was able to level up approx. 40-50 levels. 

1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.