Jump to content

Pioneering Pro [Bugged?]

Recommended Posts

18 hours ago, KamikazeAttacks said:

I repaired the hydroculture plant, and the trophy didn't pop. Tried loading and redoing it, nothing has helped.
Wondering if anyone else has had this problem or has a solution.  I cant find any information about it online. Playing on PS5.

So apparently the problem was that i had installed the season pass content and then deleted it not caring about friendships with the added dlc characters/costumes. reinstalling the added content back and then restoring the building worked. Kinda weird it wouldn't pop because of that, but oh well.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...