Jump to content

Patch 1.07 Released Today


Recommended Posts

Patch 1.07 just released. I was quite enjoying the game, but noticed the trophy involving jumping across the large gap didn't pop so I came here and saw these posts. This was on version 1.06.


Can anyone who has had glitches with the ending/trophies speak to if this newest patch fixed the issues? Don't want to have a trophy earned unless everything is properly obtainable again.

  • Like 2
Link to comment
Share on other sites

I woke up to a surprising email from them. I submitted a ticket to customer service a week ago because the game kept crashing when I picked up the adra letter and the game froze at the end.

The email was as follow:


Hi there!

Thanks so much for submitting a ticket about your issues in OXENFREE. There is a new patch on PlayStation that resolves this issue and a few other fixes:
– PlayStation trophies such as "Renjamin Spanklin" and "It's a Me" are now fixed.
– Picking up an Adler letter no longer crashes the game.

Ren’s ending now progresses.

– Climbing ladders, cliffs, and other objects is possible.

If you are still experiencing issues, please let us know by opening a new support ticket. We appreciate your help and patience as we have worked through these issues.


I only had one experience where I got stuck climbing but after wiggling and a few minutes later I was able to climb. I've heard stories were people got hard stuck and had to hard reset the game.

Only point 2 and 3  was mentioned to them by me, but I guess numerous people must have mentioned 4 of these points. It's nice to know that theyve gone and fixed it swiftly.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...