Jump to content

Overachiever trophy bugged?


Recommended Posts

So I played the whole game in local co op and definitely got A+ on every level. The honor roll trophy popped on our 10th level but not overachiever. Even went back and sped through some levels but no still no luck. 


Has this happened to anyone else?  

Edited by Jaydos12
Link to comment
Share on other sites

18 hours ago, proud2bNs said:

Yes. Delete your save file (on console) and replay all levels on a fresh save file. That fixed it for me.

Yeah that I guess that's the only way. At least you can speedrun it pretty fast once you know all the answers. Thanks 

Link to comment
Share on other sites

  • 4 months later...
  • 7 months later...
  • 5 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...