Jump to content

Corrupted Application Before I Start The Game

Recommended Posts

So i got this game to play with some friends. Put the disk in, let it install and update and it was all good. Went to play it and the game said it had to install, fair enough i thought, ill just wait a bit. Then as soon as the installs done, game freezes, take me back to the the PS home page and says "the application data is corrupted, delete application and remove disk to continue." So i was like, WTF, but i did it all and tried installing it again. THE GAME HAS CRASHED ON ME 3 TIMES NOW WITH THE FURTHEST IM MAKING IT IS CHARACTER CREATION. And its giving me the same message everytime. Is this happy to anybody else or is it just me? And if this has happened to you, any suggestions on how to fix it would be great.


Thanks if anyone can help 

Link to comment
Share on other sites

11 minutes ago, StrickenBiged said:

Tried rebuilding the PS4's database?


If that doesn't work, can you try it on another PS4 to see if the fault is the disc or your machine?

When it happened the first time, my console crashed and it said it rebuilt the database then and it still hasnt work.


And ive seen a friend play it on his machine and it worked fine, so it might be my console, but every other game i own still works fine on it, so i dunno whats up with it 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...