Jump to content



Recommended Posts

On 3/4/2020 at 7:26 PM, Charly_Py said:

Hello! Y bought the game today, and Im having problems with the academy, I cant download or upload anything as I get the message academy not available... is this normal? Or some king or maintenance issue?

I don’t know, I started the game today too and can’t access to academy either. Seems like we had real bad luck. At the moment the Set the Scene trophy isn’t achievable. I hope this gets solved quickly.


Edit: Now it seems to be working but when I try to share a scenario I get the message “permission denied”. Am I doing something wrong?


Edit 2: Problem is solved now and trophy is achievable again.

Edited by Djeheuty
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...